EP Critical fortran error and biomet issues

Environmental Forum Forums EddyPro EP Critical fortran error and biomet issues

Tagged: , ,

This topic contains 5 replies, has 3 voices, and was last updated by  IsraelB 3 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #4028



    I’m trying to process my data in EddyPro v6.0, on a new dataset having not used EP since v4.0 and have 2 main issues.

    See bottom of post for errors:

    EddyPro is not recognising the data in my external biomet file. I’ve attached my biomet file, which should be following all the correct formatting. The only issue I can think of is that the dd,hh etc. are sometimes 1 character long where EP might be expecting two characters i.e 2 vs. 02. If so, how can I reformat my timestamp or save the biomet csv file to keep the leading zeroes and have EP happy with the file?

    I also encounter an error when running EddyPro.
    I’m feeding in 10Hz data compiled within 1 day csvs. Some csvs the error comes up at the start of the processing, other times part way through. What could be causing this critical runtime error? Each file has the full 864000 datapoints, and the error doesn’t seem to correspond with nulls in the data.

    Biomet error
    Error(73)> The label of at least one biomet variable misses
    Error(73)> or has incomplete positional qualifier (“_x_y_z” suffix).
    Error(73)> EddyPro will proceed without using biomet data.

    Critical Fortran runtime error
    2015-11-19 16:43:52.039: processing new flux averaging period
    From: 2015-05-12 06:54
    To: 2015-05-12 06:55
    File(s): ..\ECfast_Ginn_all_150512_0000trimmed.csv
    Number of samples available for this period: 598
    Verifying time series integrity.. Done.
    Calculating statistics.. Done.
    Calculating user statistics.. Done.
    Raw level statistical screening..
    Spike detection/removal test..
    Spike detection/removal test..At line 113 of file test_spike_detection_vickers_97.f90
    Fortran runtime error: Index ‘599’ of dimension 1 of array ‘set’ outside of expected range (1:598)

    • This topic was modified 3 years, 6 months ago by  ivan.s. Reason: More detail


    Hi Ivan,
    Here is some information from EddyPro manual regarding the Biomet data format.
    You want to add _X_y_z to your biomet variables. These are positional qualifier to identify if you have a profile or repetitions.
    Also (despite what is written in the manual) you want to use standard (fixed) formats for time and date. That is to say use two digits for month, day, hour and minutes. You can format it in Excel by selecting the appropriate columns -> Format Cells -> Custom -> use ’00’ as the custom Type.

    The other error seems to indicate the raw data file is not properly read by EddyPro. Make sure there are no changes in structure inside the files. Does it have all the columns all the time?



    Hi IsraelB

    Thanks for your reply, I completely missed the x_y_z placeholders,and now is being registered by EP. However, regarding changing the formatting of the timestamps, I’ve done this (and have checked opening in notepad++ that the formatting is applied), but now when I run EP, it gets stuck on the first minute (no error, but after 10min it hasn’t moved on to the next minute’s averaging),and it appears to be stuck ‘searching the Biomet data in file’. I’ve attached updated biomet file. Could there be a problem using 30 minute biomet when wanting 1 minute averages? Or if the biomet file contains additional data not relating to thwe time being run?

    With regards to the fortan error, I am near 100% certain my files do not change structure at all, and that each file keeps all the columns throughout the file (with null data registered as NaN meaning there’s no blank space in file that could be considered as such). I’m confident as I’ve reprocessed them all to fill in datagaps and standardise formatting. Strangely though I’ve had a couple files run through without incident, which have no differences to the problem files. What am I able to do here?



    Hi Israel

    I’ve also shared an example of the file I’m working with on the following dropbox link. (If the upload hasn’t worked tonight, I’ll try from my home computer tomorrow)





    I’m also getting Fortran errors. Mine are slightly different though (see below):

    Critical> Interpreting biomet data..At line 89 of file biomet_subs.f90
    Critical> Fortran runtime error: Index ‘1’ of dimension 1 of array ‘bvars’ above upper bound of 0

    I’m confident that my data format is correct based on what is on the help file. I’m attaching my biomet data as well here.



    I used EddyPro version 6.1.0 with your data file without a problem.
    What version are you using?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Comments are closed.