Problem processing data using flags in EddyPro 5.1.1

Environmental Forum Forums EddyPro Problem processing data using flags in EddyPro 5.1.1

This topic contains 0 replies, has 1 voice, and was last updated by  Artem Budishchev 5 years, 1 month ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1509

    Artem Budishchev
    Participant

    Hi, I’m having a problem processing my dataset with EddyPro 5.1.1, when using diagnostic data as flags (AGC and RSSI).

    So the problem is that, if I have a gap in the raw dataset, when using said flags EddyPro throws me this error:

    Number of samples available for this period: 18000
    Verifying time series integrity.. Done.
    At line 65 of file filter_data_for_diagnostics.f90
    Fortran runtime error: Index '17611' of dimension 1 of array 'diagset' above upper bound of 17610

    I think this happens right after a bunch of errors like:

    Warning(53): no raw data file relevant to current averaging period was found.
    Skipping to next averaging period.

    Which is okay, since I indeed have a gap in the raw data. At first I thought that there’s a problem with my file, but I tried removing this file from the dataset and then the problem arises with the next file.

    So this can probably be related to a 5.1.0 bug?

    Also, this doesn’t happen if I remove all the flags, then EddyPro can finish processing the data gracefully.

    [UPDATE] I tried processing the data, starting with the problematic file and using flags, which worked okay. So now I have some confidence that this problem is somehow related to the 5.1.0 bug.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Comments are closed.